WTH? I recently upgraded my iPhone to IOS5.1. I thought that was great until I tried to install my app built with Xcode 4.2 on my phone. Xcode 4.2 doesn’t work with IOS5.1…only 5.0 and below! Well, my Mac OS was 10.6.8 so I couldn’t use Xcode 4.3. I needed Mac OS 10.7. Rather than try to get my iPhone back to IOS 5.0, which is very complicated, I decided to get to Mac OS 10.7. So, I needed 10.7 to get 4.3 so I can use 5.1. Are you following this?
I went up to a tech to get Mac OS 10.7 and I said, “I need 10.7 so I can use 4.3 in order to work with 5.1. Right now, I have 10.6.8 and 4.2 so I can’t use 5.1 because 4.2 only works with 5.0.” Holy smokes! the guy knew exactly what I was talking about and got me 10.7.
Now, I’m doing the 4.3, but it won’t work unless I have 10.7.3. Now, I’m getting that. What’s up with those Apple people and their version numbers? Jeez Louise.